* recentプラグインが動作しない [#yca53027]

- ページ: BugTrack
- 投稿者: [[argama147]]
- 優先順位: 重要
- 状態: 完了
- カテゴリ:
- 投稿日: 2012-05-12(<abbr class="week_sat" title="土曜日">土</abbr>)10:39:26
- バージョン: https://github.com/logue/pukiwiki_adv/commit/cd5a8cabbda9ac9ea23899eca62fb853343bc246

** メッセージ [#bdcba22d]
BugTrack/3dで対応していただいた~
https://github.com/logue/pukiwiki_adv/commit/cd5a8cabbda9ac9ea23899eca62fb853343bc246
で「test」というページを作成し、ページ内に

 #recent(20)

と記述すると、
Undefined variable: script in (パス省略)wiki-common\lib\trackback.php on line 90
というエラーが発生する。

原因も判明しています。
trackback.phpのtb_send()内で、
$scriptがグローバルでも設定もしていません。

○修正案~
関数の先頭に、
 $script = get_script_uri();
を追加する。

上記修正で直りました。

--------

#comment