*PHP5.4対応について [#jc4982e6]
PukiWiki Advanceでは初期の段階からPHP5.3で、error_reportingをE_ALLというシビアな環境で開発しています。初期では、様々なE_DEPRECATEDエラーが起きていましたが現在は概ね安定しています。しかしながら、http://php6.jp/2012/03/02/php5-4-0-released/によると、PHP5.3のサポートがこのPHP5.4リリースから1年半程度と考えると、PHP5.3に対応だけでは充分でないと考え、5.4への移行をすることにしました。

ざっと、開発環境を5.4に移行してみたところ、クラス内関数にstaticが含まれていないというエラーが多く見られましたが、さほど難しいという感じではありませんでした。ほぼ問題なく移行できると思います。