古いコードの削除

PukiWikiでは、プラグインを呼び出すときにpluginとcmdパラメーターを使用します。昔はpluginパラメーターを使っていましたが、1.4系列になってからはcmdパラメーターを使用することが推奨されています。これでは統一性が持てないので、pluginパラメーターを用いた呼び出しを禁止しました。今回の修正は、それが目的です。

また、global $script;でスクリプトのアドレスを取得するのもセキュリティの問題で削除しました。今後は、get_script_uri()命令を使用してください。プラグインのアクションコマンドは、Plus!より追加された以下のコードを使うといいでしょう。

$link = get_cmd_uri(プラグイン名, ページ名, アンカー名, パラメーター配列);

例えば、cmd=search&word=テスト&type=ANDという出力を出したい場合は、

$link = get_cmd_uri('search', null, nul, array('type'=>'AND');

というようになります。